We are trying to catch the slow loading bug -- please help!

Please report all loading issues, at the time they happen, on the chatbox, with the hashtag #slowloading!

That way we can later search the database for all the messages and try to find some correlations …

Thank you, and please bear with us while we resolve this!! :pray:

Thank you for all the reports so far. No conclusive findings yet :confused:

We compared the indicated slowdowns to the server activity and found this (horizontal red lines show intersection points with the database server’s cpu graph where catchers indicated a slowdown):

It looks like the server shows more activity when catchers experience slow-downs, but it isn’t an obvious relationship…

####Please keep reporting – we gotta catch it eventually! :beetle:

Here are some of my “Client side” error messages that I get when I freeze up. It seems to cluster around the “Failure to load resource.” For what it is worth.

engine.io-client:socket socket receive: type “pong”, data “undefined” +91ms
az_b03ff22fc07a4b00acac3335794739fe.mp4:1

Failed to load resource: net::ERR_SPDY_PROTOCOL_ERROR
az_a325a9fbc4b94b4eac0be5ee6b764bbe-001.jpg:1

Failed to load resource: net::ERR_SPDY_PROTOCOL_ERROR
18all-8deb464b46.js:2

Uncaught TypeError: Cannot read property ‘code’ of null
at VirtualMicroscope.VM. (all-8deb464b46.js:2)
at HTMLVideoElement.i (jquery.min.js:2)
(anonymous) @ all-8deb464b46.js:2
i @ jquery.min.js:2
az_a325a9fbc4b94b4eac0be5ee6b764bbe.mp4:1

Failed to load resource: net::ERR_SPDY_PROTOCOL_ERROR
socket.io.js:3524 engine.io-client:socket writing ping packet - expecting pong within 60000ms +25s
socket.io.js:3524 engine.io-client:socket flushing 1 packets in socket +1ms
socket.io.js:3524 engine.io-client:socket socket receive: type “pong”, data “undefined” +50ms
socket.io.js:3524 engine.io-client:socket socket receive: type “message”, data “2[“chatbox:addMessage”,{“id”:7056,“userId”:4,“senderName”:“seplute”,“email”:”",“content”:“oh cmon”,“pin”:false,“color”:“black”,“created”:“2019-03-09 15:08:08”,“convId”:1}]" +12s

1 Like

It seems the recent “troubles” manifest differently on different platforms/browsers. In case it’s not been clearly reported already, for me, aside from very extended load times depending upon the activity of certain other superusers, (and the usual but brief slowdowns on the hour, half-hour, sometimes at the 3/4 hour, and occasionally the 10-minute intervals - which are not a big problem); my major nuisance is having to refresh the screen so often, even when load times are quite good.
I have to refresh when the loading bar hangs up at the left end - despite the fact that the movie has fully loaded and the slide bar is active. Frequency is variable. Sometimes it’s only 10% of the movies, but other times it’s 90% of the movies, which becomes rather tedious. All the frames are visible, but annotation is not possible until the screen is refreshed.

2 Likes

Today’s hangs are a little different than in the past. Before I would totally freeze and even a refresh would not fix the problem. I needed to log off and come back ~5 to 10 minutes later before it would reset and load the next movie.

Currently the hangs just give me the spinning wheel on the video and it is slightly grayed out. I am able to refresh and it will reload the vessel and I can continue. This is happening 10-20% of the time.

The following messages are logged in the Chrome Console Log. The first two “Failure to load resource” messages seem to be related to google analytics and a subsequent call to doubleclick. These messages occur with every movie all the time. The “Mixed Content” error also occurs on a regular basis. The “Uncaught TypeError” is unique to the hangups being experienced today.

Let me know if I can provide any other data.
Guy

Failed to load resource: the server responded with a status of 499 ()
stats.g.doubleclick.net/r/collect?v=1&aip=1&t=dc&_r=3&tid=UA-89249330-1&cid=1590915475.1492101754&jid=1191758429&_gid=1209744678.1553137023&gjid=279329124&_v=j73&z=110789299:1

Failed to load resource: the server responded with a status of 499 ()
virtualMicroscope?autoscroll=0&showFeedback=1:1

Mixed Content: The page at ‘https://stallcatchers.com/virtualMicroscope?autoscroll=0&showFeedback=1’ was loaded over HTTPS, but requested an insecure image ‘http://loadinggif.com/images/image-selection/3.gif’. This content should also be served over HTTPS.
all-8deb464b46.js:2

Uncaught TypeError: Cannot read property ‘movie’ of undefined
at VirtualMicroscope.VM. (all-8deb464b46.js:2)
at Object.i [as success] (jquery.min.js:2)
at u (jquery.min.js:2)
at Object.fireWith [as resolveWith] (jquery.min.js:2)
at k (jquery.min.js:2)
at XMLHttpRequest. (jquery.min.js:2)

On a brighter note. I have noticed that my CPU usage by Chrome when viewing Stallcatchers pages is back to normal. This improved a week or so ago. Not exactly sure which day it was, but it happened around the time the ChatBox was deactivated. Now it still seems to be normal with the Chatbox reactivated. Yay!!!

Thank you, @gcalkins, that’s some good news at least!

Shared your error logs with @pietro for continued investigation later today …

Hey Seplute,

When you say report in the chatbox, do you mean the chatbox on the far right from the movie?
I’ve been clicking the flag under the movie, and typing slow loading movie in the “community answers” box that comes up after I annotate, under the movie.

Which one, (if not either), should I be doing.

Thanks

We meant the regular catchers real time chatbox but then at one point we asked to stop reporting :smiley:

Are you experiencing slow loading again, often?!

Good day seplute,
Yes, but I know we (you and I, as well as gcalkins) have talked about me using MS Edge, and that not being the best one for this site. So it probably has been on my end.

I also didn’t “get the memo” about stopping reports. SO - I won’t bother again, unless yo think I still need to do something. I can still do everything else very well.

Thanks again seplute,

chairgaf

“Slow” is a relative term. While load times are significantly improved over the dismal situation this past winter, mine (and at least a couple other catchers’) have yet to fully recover back to where they were before the Megathon. About 85% of my movies load in 4-5 seconds. The rest load in 1-2 seconds, same as the load times we used to enjoy what seems like ages ago. (Before the megathon, my load times had improved to a fairly consistent three seconds.) I do note that in the last couple days, load times seem a half-second faster, but I’m still idling about 50% of the time while movies load. It would be great to get back to where they almost all loaded in under two seconds.

1 Like

Noted and passed along to Pietro…

Quick note about it from him:

if these are simply load times due to the movies loading in (cloud storage network performance), then there’s not much we can do. but i think it’s more likely this is due to query time. and that’s something we can fix… it’s on the to-do!

1 Like

Here’s an update about the recent updates that improved loading speeds: https://blog.eyesonalz.com/improved-speeds-in-stall-catchers/

Hey folks,

I am having a problem with a security error coming up when I click on this link. Is it because it could be too old? is there another link to try?

Thanks,

chairstar

I AM VERY EMBARRASSED TO ASK THIS QUESTION AFTER SO LONG! Just putting that out there.
Typing in the time that we get a slow/no load into the chatbox, I get.

I guess my question is, should we also click the orange flag, and if so, before or after we necessarily need to do a refresh on our computers.

This one has been bugging me for a little while now, just - like I said - feel stupid asking after being here on SC for so long.

Thanks,

John D. Krull

John, I just now tried the link and it worked OK. Perhaps you should give it another shot. If that fails, just go to the blog and scroll down a bit to find the improved speed post.
Not sure it’s necessary to note the occasional freeze-up / refresh times any more, unless they are becoming frequent or difficult to recover from. Regardless, I don’t think clicking the flag is necessary, but Admin can correct me if not correct.
Best,
Mike C.

1 Like

Thanks Mike.

I’ll just refresh, and as you said, only report them if they become too much of “an annoyance”.

John Krull (chairstar)

1 Like

Nope, Mike is right - the flag is not necessary for this (and probably wouldn’t register anyway if you end up refreshing…)